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FedEx Web Services 2021 –  
the new standard for FedEx Shipping
As part of our commitment to delivering a state-of-the-art shipping experience to you,  
we are ready to offer the latest 2021 version of FedEx Web Services, specifically designed 
to streamline and strengthen your operations. 

To benefit from the full range of FedEx capabilities, upgrading to the new version  
is mandatory.

3 key facts you need to know

Any older version of FedEx Web Services  
will no longer be supported

We’ve added features that will allow you to 
enhance your own operations and unlock new 
opportunities for your business

Upgrading will mean you benefit faster from 
our expanding range of services, such as our 
dedicated new economy and express services

This document will guide you through the required changes for updating your existing Web 
Services version to the current 2021 release of FedEx Web Services.
Not all features are covered in this guide. If you should encounter any issues or require further 
assistance, do not hesitate to contact your FedEx Customer Technology representative.
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Technical changes for upgrading  
FedEx Ship Requests v10 to v28 (2021)

Endpoints
There are new endpoints – in the future use for 	
Production:	 https://ws.fedex.com:443/web-services/ship
Test:	 https://wsbeta.fedex.com:443/web-services/ship
The old endpoints are still working but will be decommissioned in the near future. 
Effective May 29, 2021, FedEx will no longer accept a security protocol below TLSv1.2 for any 
of our production web services gateway servers. After that date, any communication requests 
submitted to FedEx using a security protocol below TLSv1.2 will fail.

FedEx Label on A4 (PDF)
For customers creating FedEx labels in A4 (PDF), a new AWB format has been introduced for 
FedEx shipping labels. Please hand all paperwork provided in the reply over to the courier. 
There are now two different formats in the reply, both are required for a complete FedEx 
shipment.

Pending Shipments
If you are creating pending shipments in version 10, please contact your CT representative, as 
this is not possible in the shipping request of the current version (v28) anymore.

https://ws.fedex.com:443/web-services/ship
https://wsbeta.fedex.com:443/web-services/ship
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Electronic Trade Documents
FedEx® Electronic Trade Documents (ETD) is the best way to exchange customs paperwork 
information with us. It allows you to transmit customs documentation electronically for  
your international shipments.

We strongly encourage FedEx customers who have not adopted this setup yet to make  
the transition as soon as possible.

Benefits of ETD

Save time when preparing your shipments: you no longer 
have to print, sign, fold and attach your trade documents 
to each shipment.

Minimise the risk of customs delays by allowing for a 
quicker documentation review: you are notified earlier of 
potential errors or missing paperwork.

Save money and reduce your carbon footprint: lower your 
consumption of paper and toner for your international 
shipments, as only one shipping label is required.
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Implementing ETD

Choose one of the following three processes for using ETD:

When one or both of the origin or destination countries do not accept paperless clearance, 
ETD will trigger the ‘Electronic with Original’ (EWO) option.
EWO is stated in the Shipment Reply of your XML request to FedEx, and it is also printed on 
the FedEx label. This makes it easy to identify when to trigger printing for IT systems. And for 
personnel, it means they know when to attach paperwork to their physical packages.
In this case, you can seamlessly upload your customs documents electronically to benefit from 
an early broker review, but you will still have to attach printed copies of customs documents to 
your shipment to comply with regulatory requirements.

Contact your FedEx CT representative for more details and guidance to optimise or 
implement ETD. 

Version
Only the version ShipRequest (V26) and higher supports the new FedEx Service portfolio. 
Please access the resources at FedEx Web Services | FedEx Developer Resource Center  
to download all relevant documentation and WSDLs (you will need to be logged in first).
Should you encounter issues when moving to the 2021 version of FedEx Web Services,  
do not hesitate to reach out to the FedEx Customer Technology team.

Option 1
 
 

Option 2 

 

Option 3

Let FedEx create the paperwork for you
This is ideal for simple shipping scenarios. FedEx can create a commercial 
or pro forma invoice and, where needed, a Certificate of Origin for you 
without the need for these documents to be printed.

Create the paperwork yourself and upload it  
before you print the label
This is ideal if your paperwork is available before you create the  
FedEx shipping label.

Upload the paperwork immediately after  
creating the FedEx shipping label
This is ideal for customers who use a complex process to generate the 
required documents and who are unable to produce the paperwork 
before or during the creation of their FedEx shipping label.

https://www.fedex.com/en-us/developer/web-services/process.html#AdvancedServices
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Necessary changes in specific elements  
of the FedEx Ship Request

<ShippingChargesPayment>
The <ShippingChargesPayment> element has been updated. <ResponsibleParty> has been 
inserted and is now mandatory.
<CountryCode> has become optional in the latest version and it is recommended to remove it, 
otherwise it must be embedded in the <Address> element.

Version 10 Version 28 (current)

<ShippingChargesPayment>
    <PaymentType>SENDER</PaymentType>
         <Payor>
             <AccountNumber>xxx</AccountNumber>
             <CountryCode>xx</CountryCode>
         </Payor>
</ShippingChargesPayment>

<ShippingChargesPayment>
               <PaymentType>SENDER</PaymentType>
            <Payor>
               <ResponsibleParty>
                  <AccountNumber>xxx</AccountNumber>
               </ResponsibleParty>
            </Payor>
</ShippingChargesPayment>

If you wish to preserve the <CountryCode>, you have to newly embed it into the 
<Address> element, however, it is not mandatory to submit <CountryCode>

<ShippingChargesPayment>
     <PaymentType>SENDER</PaymentType>
     <Payor>
       <ResponsibleParty>
       <AccountNumber>xxx</AccountNumber>
          <Address>
             <CountryCode>xx</CountryCode>
          </Address>
       </ResponsibleParty>
     </Payor>
</ShippingChargesPayment>
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<DutiesPayment>
The <DutiesPayment> element has been updated. <ResponsibleParty> has been inserted and 
is now mandatory.
Exception: If <PaymentType> is RECIPIENT in <DutiesPayment>, <ResponsibleParty>  
is optional.
<CountryCode> is optional in the latest version and it is recommended to remove it, otherwise 
it needs to be embedded in the <Address> element.

Version 10 Version 28 (current)

<CountryCode>DE</CountryCode>
               </Address>
            </Recipient>
<DutiesPayment> 
               <PaymentType>SENDER</PaymentType>
               <Payor>
                   <AccountNumber>xxx</AccountNumber>
                   <CountryCode>xx</CountryCode>
               </Payor>
</DutiesPayment> 

<CountryCode>DE</CountryCode>
               </Address>
            </Recipient>               
<DutiesPayment> 
               <PaymentType>SENDER</PaymentType>
               <Payor>
                 <ResponsibleParty>
                    <AccountNumber>xxx</AccountNumber>
                 </ResponsibleParty>
               </Payor>
</DutiesPayment>

If you wish to preserve the <CountryCode>, you have to newly embed it in 
the <Address> element, however, it is not required to submit <CountryCode>

<DutiesPayment> 
               <PaymentType>SENDER</PaymentType>
               <Payor>
                 <ResponsibleParty>
                   <AccountNumber>xxx</AccountNumber>
                     <Address>
                        <CountryCode>xx</CountryCode>
                     </Address>
                    </ResponsibleParty>
               </Payor>
</DutiesPayment> 

<PackageDetail>
The optional <PackageDetail> element has been removed. It is no longer needed and there is 
no replacement.

Version 10 Version 28 (current)

<PackageCount>1</PackageCount>
            <PackageDetail>INDIVIDUAL_PACKAGES</PackageDetail>
            <RequestedPackageLineItems>
               <Weight>
                  <Units>KG</Units>
                  <Value>5.0</Value>
               </Weight>

Not needed anymore, no replacement

Notes: �If you are using PACKAGE_GROUPS or PACKAGE_SUMMARY in 
this element, please contact your CT representative for the next 
recommended steps.
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<RateRequestTypes>
<RateRequestTypes> indicates the type of rates to be returned. Valid values are:

•  LIST — Returns both account-specific (discounted) rates and standard published rates. 
•  �PREFERRED — Returns account-specific rates in the currency specified in the 

<PreferredCurrency> element, if the element is included in the request.
•  NONE — Returns no rates in response.

To receive account-specific rates in your base currency only, do not send this element in the 
request at all.
The previously used value ACCOUNT is still usable, but will not work in the current version 
(v28) anymore. For comparable functionality, use PREFERRED.

Version 10 Version 28 (current)

<RateRequestTypes>ACCOUNT</RateRequestTypes> <RateRequestTypes>PREFERRED</RateRequestTypes>

If you wish to have account-specific rates returned in a currency different to the base currency 
of your account, use the new element <PreferredCurrency> to specify the desired currency of 
the rate quote. This may differ from the currency you declare in your ship request.

Version 10 Version 28 (current)

Not available <RequestedShipment>
            <ShipTimestamp>2009-08-12T09:30:47-01:00</ShipTimestamp>
            <DropoffType>REGULAR_PICKUP</DropoffType>
            <ServiceType>INTERNATIONAL_PRIORITY</ServiceType>
            <PackagingType>YOUR_PACKAGING</PackagingType>
            <PreferredCurrency>CAD</PreferredCurrency>
            <Shipper>
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<Terms of Sale>  
if using FedEx-generated commercial/pro forma invoice
When using a FedEx-generated commercial/pro forma invoice, the list of permitted values has 
changed. FedEx recommends the use of Incoterms 2010.

Version 10 Version 28 (current)

Terms of Sale (Incoterms Updates)

<TermsOfSale>xxx</TermsOfSale>

FOB_OR_FCA
CFR_OR_CPT
CIF_OR_CIP

These Incoterms are still supported but must now be specified individually if used. 
Alternatively, the new values of Incoterms 2010 are now available.

The complete list of valid Incoterms supported by FedEx Web Services now is:
FOB
FCA
CFR
CPT
CIF
CIP
DDP
DDU
DAP
DAT
EXW

FedEx recommends the use of Incoterms 2010.

<CustomerInvoiceNumber>  
if using FedEx generated-commercial/pro forma invoice
The <CommercialInvoiceNumber> element has changed. The commercial invoice information 
now needs to be provided in a new <CustomerReferences> element as shown below. 
Please be aware that in v10 the element <DeclarationStatment> did accidentally miss an “e” in 
Statement. This has been corrected in the following versions.

Version 10 Version 28 (current)

     <SpecialInstructions>[Special Instructions Field]</SpecialInstructions>
     <DeclarationStatment>[Declaration Statement]</DeclarationStatment>
     <PaymentTerms>[Payment Terms Field]</PaymentTerms>
     <Purpose>REPAIR_AND_RETURN</Purpose>
     <CustomerInvoiceNumber>[CommercialInvoiceNumber]</CustomerInvoiceNumber>
     <OriginatorName>[OriginatorName]</OriginatorName>
     <TermsOfSale>DDU</TermsOfSale>
</CommercialInvoice>

     <SpecialInstructions>[SpecialInstructions]</SpecialInstructions>
     <DeclarationStatement>[DeclarationStatement]</DeclarationStatement>
     <PaymentTerms>[PaymentTerms]</PaymentTerms>
     <Purpose>REPAIR_AND_RETURN</Purpose>
     <CustomerReferences>
          <CustomerReferenceType>INVOICE_NUMBER</CustomerReferenceType>
                    <Value>111111</Value>
          </CustomerReferences>
     <OriginatorName>[OriginatorName]</OriginatorName>
     <TermsOfSale>DDU</TermsOfSale>
</CommercialInvoice>
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<Broker Select Option>
The element <Broker> has been updated. The <Brokers> element has been added as 
mandatory and now encloses the <Broker> element.
An additional mandatory <Type> element has been introduced. The setting for the normal use 
of the BROKER_SELECT_OPTION is IMPORT. 
Exception: If a shipment originates in Mexico, an EXPORT broker can be specified.

Version 10 Version 28 (current)

            <SpecialServicesRequested>

<SpecialServiceTypes>BROKER_SELECT_OPTION</SpecialServiceTypes>
            </SpecialServicesRequested>
            <CustomsClearanceDetail>
               <Broker>
                  <Contact>
                     <PersonName>Mr Broker</PersonName>
                     <CompanyName>Broker Corporation</CompanyName>
                     <PhoneNumber>5556667777</PhoneNumber>
                     <EMailAddress>skjapan@doesnotexist.de</EMailAddress>
                  </Contact>
                  <Address>
                     <StreetLines>Ave de Broker</StreetLines>
                     <StreetLines>Numero 2</StreetLines>
                     <City>BEVERLY HILLS</City>
                     <StateOrProvinceCode>CA</StateOrProvinceCode>
                     <PostalCode>90210</PostalCode>
                     <CountryCode>US</CountryCode>
                  </Address>
               </Broker>

    <SpecialServicesRequested>

<SpecialServiceTypes>BROKER_SELECT_OPTION</SpecialServiceTypes>
            </SpecialServicesRequested>
            <CustomsClearanceDetail>
             <Brokers>
             <Type>IMPORT</Type>
               <Broker>
                  <Contact>
                     <PersonName>Mr Broker</PersonName>
                     <CompanyName>Broker Corporation</CompanyName>
                     <PhoneNumber>5556667777</PhoneNumber>
                     <EMailAddress>skjapan@doesnotexist.de</EMailAddress>
                  </Contact>
                  <Address>
                     <StreetLines>Ave de Broker</StreetLines>
                     <StreetLines>Numero 2</StreetLines>
                     <City>BEVERLY HILLS</City>
                     <StateOrProvinceCode>CA</StateOrProvinceCode>
                     <PostalCode>90210</PostalCode>
                     <CountryCode>US</CountryCode>
                  </Address>
               </Broker>
               </Brokers>

<Dangerous Goods in Excepted Quantities>
The element <DangerousGoodsDetail> has been updated when shipping Dangerous Goods in 
Excepted Quantities. It is no longer required to specify <Accessibility> when using the SMALL_
QUANTITY_EXCEPTION option in the <Options> element.
The <Accessibility> continues to be used to declare accessibility for fully declared Dangerous 
Goods requiring a Dangerous Goods Shipper’s Declaration.

Version 10 Version 28 (current)

<SpecialServicesRequested>
   <SpecialServiceTypes>DANGEROUS_GOODS</SpecialServiceTypes>
     <DangerousGoodsDetail>
        <Accessibility>ACCESSIBLE</Accessibility>
        <Options>SMALL_QUANTITY_EXCEPTION</Options>
     </DangerousGoodsDetail>
</SpecialServicesRequested>

<SpecialServicesRequested>
     <SpecialServiceTypes>DANGEROUS_GOODS</SpecialServiceTypes>
         <DangerousGoodsDetail>
                <Options>SMALL_QUANTITY_EXCEPTION</Options>
          </DangerousGoodsDetail>
</SpecialServicesRequested>

Notes: �It is also possible to specify Dangerous Goods in Excepted Quantities 
as a commodity with zero value – it is recommended to use the 
appropriate flag instead.
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<Email Notification>
The <SpecialServiceTypes> EMAIL_NOTIFICATION with the <SpecialServicesRequested> 
at shipment level has now changed to be EVENT_NOTIFICATION. This has also resulted in a 
change to <EMailNotificationDetail> element:

Version 10 Version 28 (current)

<SpecialServiceTypes>EMAIL_NOTIFICATION</SpecialServiceTypes>
  <EMailNotificationDetail>
    <Recipients>
<EMailNotificationRecipientType>RECIPIENT</EMailNotificationRecipientType>
                     <EMailAddress>email@address.com</EMailAddress>                     <Notifica-
tionEventsRequested>ON_DELIVERY</NotificationEventsRequested>
<NotificationEventsRequested>ON_EXCEPTION</NotificationEventsRequested>
<NotificationEventsRequested>ON_SHIPMENT</NotificationEventsRequested>
<NotificationEventsRequested>ON_TENDER</NotificationEventsRequested>
                     <Format>HTML</Format>
                     <Localization>
                        <LanguageCode>EN</LanguageCode>
                     </Localization>
    </Recipients>
  </EMailNotificationDetail>

<SpecialServiceTypes>EVENT_NOTIFICATION</SpecialServiceTypes> 
      <EventNotificationDetail>
        <EventNotifications>
             <Role>RECIPIENT</Role>
             <Events>ON_DELIVERY</Events>
             <Events>ON_EXCEPTION</Events>
             <Events>ON_SHIPMENT</Events>
             <Events>ON_ESTIMATED_DELIVERY</Events>
             <Events>ON_TENDER</Events>
             <NotificationDetail>
                <NotificationType>EMAIL</NotificationType>
                <EmailDetail>
                   <EmailAddress>email@address.com</EmailAddress>
                   <Name>RECIPIENT NAME</Name>
                </EmailDetail>
                <Localization>
                   <LanguageCode>EN</LanguageCode>
                 </Localization>
             </NotificationDetail>
             <FormatSpecification>
                <Type>HTML</Type>
             </FormatSpecification>
        </EventNotifications>
      </EventNotificationDetail>

Available Roles:
•	 BROKER
•	 OTHER
•	 RECIPIENT
•	 SHIPPER
•	 THIRD_PARTY
Available Notification Events:
•	 ON_DELIVER
•	 ON_ESTIMATED_DELIVERY
•	 ON_EXCEPTION
•	 ON_SHIPMENT
•	 ON_TENDER
Available Notification Formats:
•	 HTML
•	 TEXT
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